LatchBio - Workflow Queue Time – Incident details

Workflow Queue Time

Resolved
Operational
Started about 1 month agoLasted about 2 hours

Affected

Core Services

Degraded performance from 12:30 PM to 2:30 PM

Workflows

Degraded performance from 12:30 PM to 2:30 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    Some workflow executions experiencing > 30 but < 60 minute queue time.