LatchBio - Queued workflows not scheduling – Incident details

Queued workflows not scheduling

Resolved
Partial outage
Started 2 months agoLasted 23 minutes

Affected

Core Services

Partial outage from 4:55 PM to 5:18 PM

Workflows

Partial outage from 4:55 PM to 5:18 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating
    We are currently investigating this incident.